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Schedule
PrePre--Workshop Workshop –– Story Boards and Site DesignStory Boards and Site Design

January 14/15 – Overview and Adobe Photoshop

January 28/29 – Macromedia Flash MX

February 11/12 – Macromedia Freehand 10

February 25/26 – Macromedia Dreamweaver MX
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Information Design
Message – What do you want to say
Audience – Who are you trying to reach
Purpose – What do you want them to do with it
Background – Why you are here
Structure – How it is organized

Information is defined as the stuff on a page.  Usually there is an innate organization 
to this “stuff”.

Does the information to be contained on a site have a hierarchy, I.e. some concepts 
and ideas are more important or critical than others?
Can the information be organized into equal junks in importance?
Must the information be displayed in a “building block” fashion, I.e. concept #1 
must be learned before concept #2 before concept #3?

How the information you intend to display can be organized determines what type 
of web page or site you will create.



4

Technology Training
January-February 2003

Presentation Design
Navigation – determined by information type
Color Scheme – contrast and usage
Font Selection – standard versus enhanced
Graphics Selection – appropriate to subject
Multimedia Effects – good and bad
Layout – where is everything

English/International/Cultural 

How you want your page to look is partially determined by the information that you 
are trying to display.  However, there are as many ways to create a page as there are 
people creating pages!

Basic areas to include:
A top logo region

Show the owner/creator and the basic intent of the site
A top or left navigation area

Displays the available information on the site and allows the user a 
way to access it

A “body” area where most content and information is displayed

Optional parts:
A top navigation area that contains important, but not critical, links to other 
functions, such as contacts, help, etc.
A bottom bar that contains copyrights and direct contact information
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Before you create…..you need
A storyboard image or graphic
Element list

Navigation
Pictures
Page List or overview
Content blocks

An audience checklist
Development and Maintenance Timeline

Inspiration 6.0 is one way to develop a visual representation of your page or site.  
Most people have an easier time working with a visual view of a page than a written 
narrative.  

Pencil and paper still work, even in the 21st century!  Create a drawing of your page 
and site structure.  This will be the equivalent of the mental map that you are asking 
your viewers to build as they click through your site.  If you don’t understand the 
structure of your creation, don’t expect your site visitors to understand it either

SIMPLIFY, SIMPLIFY, SIMPLIFY!
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Macromedia Flash MX
Tool for creating animated 
vector graphics and multimedia
Timeline and object-oriented 
model
Very useful feature called
tweening which can be used to 
create animations

Specify a start and end point and 
Flash calculates all the in-
between frames of the animation

Popular format on websites

Macromedia Flash is one of the primary development tools for animation on the 
Internet.  It is the top-of-the line development environment and can be intimidating.  
However, knowledge and command of this product virtually insure that employers 
will demand your skills and development expertise.

Other packages are available that build animations in Shockwave format, but do not 
contain the full-breadth of development tools available in Flash MX:

• Adobe LiveMotion – easy animation tool, but limited graphics capabilities
• Swish – Limited development and animation tool, but accessible for 
beginners
• DigiCel – a layered animation tool designed to duplicate clay cel 
animation
• And many others.
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Flash MX Highlights
Vector graphics
Designed for the web - tiny files
Key frame animation 
Action scripts for events
True Streaming 
Sound, .wav or mp3

When it first appeared in 1996, Macromedia Flash was an uncomplicated animation 
app. Since then, the Flash file format has become the standard for interactive Web-
based multimedia. Flash MX, the graphics app of the same name, lets you fashion 
stunning, highly interactive Flash animation. 
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Flash MX Terms
Stage  
Media Elements are Instances on the stage
Library of symbols
Timeline 

Frame – a specific time and content state of a movie
Keyframe – a frame that specifies a change in a movie

Actionscripts to trigger events
Flash Alpha = Photoshop Opacity
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Flash MX Parts

Use the BIG J!
Select the Desired Tool from the Toolbox

Check Toolbox Options
Set the Property Panel Options

Do your thing on the stage
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Creating An New Animation

Modify | Document controls the properties of  
document
Dimensions – H/W in pixels
Match

Printer – max page size of  default printer
Shape – resizes stage according to the 
elements placed on it (May modify the 
spacing of the elements: not desirable)
Default – as shown in image

Background color – affects ALL frames, so 
select before starting
Frame Rate – 12 fps is adequate 95% of the 
time

File | New creates a new stage and work area.

To create a new document and set its properties:
1 Choose File > New. 
2 Choose Modify > Document. The Document Properties dialog box appears. 
3 For Frame Rate, enter the number of animation frames to be displayed every second. For most 
computer-displayed animations, especially those playing from a Web site, 8 fps (frames per second) 
to 12 fps is sufficient. 
4 For Dimensions, do one of the following:
Stage size in pixels, enter Width and Height. Default size is 550 x 400 pixels. Minimum size is 1 x 1 
pixels; Maximum is 2880 x 2880 pixels.
To set the Stage size with equal space around the content on all sides, click the Contents button to the 
right of Match. To minimize movie size, align all elements to the upper left corner of the Stage, and 
then click Contents.
To set the Stage size to the maximum available print area, click Printer. This area is determined by 

the paper size minus the current margin selected in the Margins area of the Page Setup dialog box 
(Windows) or the Print Margins dialog box (Macintosh). 
To set the Stage size to the default size, click Default. 

5 Click the triangle in the Background Color box and select a color from the palette.
6 To specify the unit of measure for rulers that you can display along the top and side of the 
application window, select an option from the pop-up menu in the upper right. 
7 Do one of the following:
To make the new settings the default properties for your new document only, click OK.
To make these settings the default properties for all new documents, click Make Default.
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HELP!!!
The Answers panel has everything 

that is new about Flash.
Press F1 at any time for HTML-
based help file.
The Flash Lessons (Help | 
Lessons) are an excellent 
introduction to Flash MX.

Two types of help are available:
1. Select Help | Using Flash from the menu or press F1.
2. Use the Answers Panel to peruse selected help on more advanced topics 

supplied by Macromedia (internet connection required)

For learning Flash MX, three other options are available:
1. Select Help | Lessons and go through each of the available sections.  Excellent 

guides for learning (or re-learning) Flash MX basics.
2. Select Help | Tutorials to receive a large list of extended lessons and guides for 

more advanced techniques.
3. Create an animation using one of the templates available from File | New from 

template.  Once exposed to HOW Macromedia created the templates, you will 
have ideas of your that can build on the techniques learned from the templates.

For a huge selection of Flash files (FLA), go to 
http://www.canfieldstudios.com/flash5/ and start downloading.
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Pointers
You can select an object with either pointer:

Black (select tool): select, drag, and reshape
White (subselect tool): select, shape, and redraw using handles

Black 
Plain: select area using rectangle marquee 
Curved line: deform selected line
Square: change angle of connected lines
4 arrows: select elements, move selection, connected object

White
Plain: select and move object
with black box: select and move object
with “open” box: select and modify point

Remember the differences and life is easier.  Each pointer has multiple functions, 
depending on where the mouse cursor resides and how you click your mouse.
Black Pointer (Arrow Tool)
Select a stroke, fill, group, instance, or text block: single click
Select connected lines: double-click one of the lines 
Select a fill and outline: double-click the fill. 
Select objects within a rectangular area: drag a marquee around the object or objects that you 
want to select. Instances, groups, and type blocks must be completely enclosed to be selected. 

White Pointer (Subselect Tool)
Display anchor points on line or fill: Click the line/shape outline.
Move an anchor point: Click point and drag the point 
Nudge an anchor point/points: Select point or points and use arrow keys to move
To adjust a straight segment: Click on straight segment and drag anchor point on segment to new 
position. 
To adjust a curve segment: drag the segment. 
Note: When you click the path, anchor points are revealed. Adjusting a segment with the Subselection tool may add points to 
the path. 

Adjust points or tangent handles on a curve:  Select anchor point on a curved segment. A tangent 
handle appears for the point you selected. Drag the anchor point, or tangent handle. Shift-drag to 
constrain the curve to multiples of 45° . Alt-drag (Windows) to drag tangent handles individually.
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Color Swatches
As a rule, select a color before touching 
the stage
Swatches show available colors
Bottom panel shows available, preset 
gradients and color flow models
Add colors using the select list (    )

Can be used to select colors, but MOST TOOLS HAVE THEIR OWN COLOR 
OPTIONS!

Use the BIG J!
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Drawing Tools
Line Tool

Inspector: line thickness, pattern, color
Custom: Type controls available options for detail
Steps: Deselect, tool, color, smoothing, options, draw
Shift key constrains: 0, 45, 90

Pencil Tool
Basically the same as line; uses line options
Three modes: Straighten, Smooth, Ink

To draw a straight line, oval, or rectangle:
1 Select the Line, Oval, or Rectangle tool. 
2 Select Window > Properties and select stroke and fill attributes in the Property inspector. 
3 For the Rectangle tool, specify rounded corners by clicking the Round Rectangle modifier (Options 
Toolbar) and entering a corner radius value. A value of zero creates square corners.
4 Drag on the Stage. If you are using the Rectangle tool, press the Up and Down Arrow keys while 
dragging to adjust the radius of rounded corners. 
For the Oval and Rectangle tools, Shift-drag to constrain the shapes to circles and squares.
For the Line tool, Shift-drag to constrain lines to multiples of 45° .
To select a stroke color, style, and weight using the Property inspector:
1 Select an object or objects on the Stage.
2 Display the Property panel, choose Window > Properties.
3 Select a color, click triangle next to the Stroke color box and: Choose a color swatch from the 
palette or type color’s hexadecimal value in the text box.
4 Select a stroke style, click triangle next to the Style pop-up menu and choose an option from the 
menu or choose custom. 5 Select a stroke weight, click triangle next to the Weight pop-up menu and 
the slider at the desired weight.
To apply a solid color fill using the Property inspector: 
1 Select an object or objects on the Stage.
2 Choose Window >Properties.
3 Select a color, click triangle next to Fill color box and do one of the following: Choose a color 
swatch from the palette or type color’s hexadecimal value in the text box.
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Pen Tools and Shapes
Creates a deformable, vectored line
Can manipulate points and angles
Combined to form complex shapes

Inspector: line thickness, pattern, color, fill color
Steps: Deselect, tool, color, smoothing, options, draw

Mouse actions
single click and drag to create a vector
Tap and point to create a line
Select a point and drag to deform
Shift key constrains: 0, 45, 90

To avoid unwanted blending, add new shapes on a new, individual 
layers

To draw precise paths as straight lines or smooth, flowing curves, you can use the 
Pen tool. You can create straight or curved line segments and adjust the angle and 
length of straight segments and the slope of curved segments. 

When you draw with the Pen tool, you click to create points on straight line 
segments, and click and drag to create points on curved line segments. 

You can adjust straight and curved line segments by adjusting points on the line 
using the White pointer (Subselect Tool). You can convert curves to straight lines 
and the reverse. You can also display points on lines that you create with other 
Flash drawing tools, such as the Pencil, Brush, Line, Oval, or Rectangle tools, to 
adjust those lines. 
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Vector Lines
Vectors are modifiable lines, controlled by anchor points
Remember Cursor Tasks!

Plain white: select and move object
Plain white with black box: select and move object
Plain White with box: select and modify point
Black with curved line: deform selected line
Black with square: change angle of connected lines
Black with 4 arrows: move entire, connected object
Plain Black: select area using rectangle marquee

Combinations of colors cancels
It is a selection modification; think alt-key in Photoshop
Node selector used after shape “completed”

Lines are the key to Flash MX.  Their creation, direction, and weight are all 
controlled by the pen and vector modification tools.  The function of these tools has 
changed as Flash has developed.  

Make sure that you practice your mouse control using the white and black pointers 
to be successful in the management of Flash MX’s lines and fills.
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Shapes
Shapes are collections of vectored lines that have a fill and border 
color
Important Rules:

Shapes have NO default connection between fill and border
All shapes can be transformed, directly or through cursors

Borders are optional and use the line options on the inspector panel
Rectangles have an added option: corner roundness
Cursors:

White cursor used to select and transform entire object
Black cursor used to select and transform individual parts of a shape

Remember: 
Shapes on the same layer are difficult to uncombine once they 
overlap! 
Create new layers to preserve a shape during all operations.
More operations for modifying shape are under Modify | Shape

Remember that “shapes” in Flash MX are an illusion.  Shapes are elements created 
by the combination of a line and a fill.  The line and fill can be modified together or 
separately.  The fill is controlled by how the lines were created and their final 
relationship to each other.

PLAY, PLAY, PLAY!
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Brushes
Similar to Photoshop brushes, but specialized
Order: deselect, brush tool, size, shape, type, draw
Types:

Normal – paints over everything
Fills – paints over fills, but not lines
Behind – paints behind objects
Selection – paints only selected areas
Inside – paints inside the area where you begin the brush stroke

To paint with the Brush tool:
1 Select the Brush tool.
2 Select Window > Properties and select fill color in the Property inspector. 
3 Click the Brush Mode modifier and choose a painting mode: 

•Paint Normal paints over lines and fills on the same layer. 
•Paint Fills paints fills and empty areas, leaving lines unaffected.
•Paint Behind paints in blank areas of the Stage on the same layer, leaving 
lines and fills unaffected.
•Paint Selection applies a new fill to the selection when you select a fill in 
the Fill modifier or the Fill box of the Property inspector. (Same as selecting 
a filled area and applying a new fill.)
•Paint Inside paints the fill in which you start a brush stroke and never paints 
lines.

4 Choose a brush size and brush shape from the Brush tool modifiers.
5 Drag on the Stage. Shift-drag to constrain brush strokes to horizontal and vertical 
directions.
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Color Selection & Gradients
Color selection is always available through the 
color swatches panel or on the toolbox
Gradients are selected from either location
Control of gradients is through the options 
selection in the color swatches panel
Gradient center determined by mouse position

To create or edit a solid color with the Color Mixer:
1 To apply the color to existing artwork, select an object or objects on the Stage.
2 Choose Window > Color Mixer.
3 To select a color mode display, choose RGB or HSB from the pop-up menu in the upper right 
corner of the Color Mixer. 
4 Click the Stroke or Fill icon to specify which attribute is to be modified. Note: Be sure to click the 
icon, not the color box, or the color pop-up window will open.
5 If you selected the Fill icon in step 4, verify that Solid is selected in the Fill Style pop-up menu in 
the center of the Color Mixer.
6 Click the arrow in the lower right corner to expand the Color Mixer.
7 Do one of the following:

•Click in the color space in the Color Mixer to select a color. Drag the Brightness control to 
adjust the brightness of the color. 
•Enter values in the color value boxes.  Enter an Alpha value to specify the degree of 
transparency, from 0 for complete transparency to 100 for complete opacity.
•Click the Default Stroke and Fill button to return to the default color settings, black and 
white (white fill and black stroke).
•Click the Swap Stroke and Fill button to swap colors between the fill and the stroke. 
•Click the No Color button to apply no color to the fill or stroke. Note: You cannot apply a 
stroke or fill of No Color to an existing object. Instead, select the existing stroke or fill and 
delete it.
•Click the Stroke or Fill color box and choose a color from the pop-up window. 
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Paint Bucket/Ink Well
Paint Bucket is for fills and closed shapes
Ink Well is for borders and non-closed shapes (lines)
Ink well will change the color of the border to a 
selected shape, adding one if necessary
Important:

Where you click as important as what is selected
Deselect all objects to ensure fine control

Use the options tool on paint bucket to:
Ignore gaps
Close small, medium, or large gaps

To use the Paint Bucket tool to fill an area: 
1 Select the Paint Bucket tool from the toolbox.
2 Choose a fill color and style (Property Inspector)
3 Click the Gap Size modifier and choose a gap size option:
Choose Don't Close Gaps if you want to close gaps manually before filling the 
shape. Closing gaps manually can be faster for complex drawings.
Choose a Close option to have Flash fill a shape that has gaps. 
Note: If gaps are too large, you might have to close them manually.
4 Click the shape or enclosed area that you want to fill.

To use the Ink Bottle tool: 
1 Select the Ink Bottle tool from the toolbox.
2 Choose a stroke color (Property Inspector)
3 Choose a stroke style and stroke width from the Property inspector. 
4 Click an object on the Stage to apply the stroke modifications. 
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Eraser
Does what it says – erases.
Types: 

Rectangle 
Ellipsis
Single Row
Single Column

Quickly delete everything on Stage: Double-click the Eraser tool. (I learn 
something new every day). 
To remove stroke segments or filled areas:
1 Select the Eraser tool and then click the Faucet modifier. 
2 Click the stroke segment or filled area that you want to delete.
To erase by dragging:
1 Select the Eraser tool.
2 Click the Eraser Mode modifier and choose an erasing mode: 

•Erase Normal erases strokes and fills on the same layer.
•Erase Fills erases only fills; strokes are not affected.
•Erase Lines erases only strokes; fills are not affected.
•Erase Selected Fills erases only the currently selected fills and does not 
affect strokes, selected or not. (Select the fills you want to erase before using 
the Eraser tool.)
•Erase Inside erases only the fill on which you begin the eraser stroke. If you 
begin erasing from an empty point, nothing will be erased. Strokes are 
unaffected by the eraser in this mode.

3 Click the Eraser Shape modifier and choose an eraser shape and size. Make sure 
that the Faucet modifier is not selected.
4 Drag on the Stage. 
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Guides and Grids
Guides are created to help you align a presentation

Display the rulers using View | Rulers
Drag from the left ruler to create a vertical guide
Drag from the top ruler to create a horizontal guide

You can lock guides and cause your objects to align to them using 
the View | Guide options.

Grids are a “behind-the-scenes” helper built into Flash MX
Display the grid by selecting View | Grid | View Grids
Use the grids for alignment by selecting View | Grid | Snap to Grid
Edit grid size and colors using View | Grid | Edit Grid options panel

To turn snapping to guides on or off: Choose View > Guides > Snap to Guides. 
Note: Snapping to guides takes precedence over snapping to the grid in places 
where guides fall between grid lines. 
To move a guide: Use the Arrow tool to drag the guide. 
To remove a guide: With guides unlocked, use the Arrow tool to drag the guide to 
the horizontal or vertical ruler. For information on locking and unlocking guides, 
see the following procedure. 

Using rulers
When rulers are displayed, they appear along the top and left sides of the document. 
You can change the unit of measure used in the rulers from the default of pixels. 
When you move an element on the Stage with the rulers displayed, lines indicating 
the element's dimensions appear on the rulers. 

To specify the rulers' unit of measure for a document: 
Choose Modify > Document, and then select an option from the pop-up menu at the 
upper right. 
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Objects
Easy part

Objects are things within your work area

Hard part
They may reside on single layers, multiple layers, be grouped or split, 

or be non-editable because of type, placement, or state.

Telling the difference is the key to using objects!

In Macromedia Flash MX, graphic objects are items on the Stage. Flash lets you 
move, copy, delete, transform, stack, align, and group graphic objects. You can also 
link a graphic object to a URL. Keep in mind that modifying lines and shapes can 
alter other lines and shapes on the same layer. 

Note: Graphic objects in Flash are different from ActionScript objects, which are 
part of the ActionScript programming language. Be careful not to confuse the two 
uses of the term. 
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Working with Objects
Raster Images, such as JPG, GIF, PNG

Defined as whole elements.  
Can be “split”, but results are sometimes unusable

Vector Images, such as Freehand, Illustrator, or CorelDraw images
Can be split into multiple layers
Can be imported as keyframes (risky, but neat)
Can be imported as layers (safe, safe, safe, but not always desirable)

Drawn Shapes and Lines
Always defined as objects
Sometimes are not editable because transforms can occur across layers, keyframes, frames, 
or groups
Grouping is a way to apply “all-or-none” to common objects

Symbols
A specific type of repeatable shape with a preset configuration 
Not always editable because of its configuration
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Importing Raster Images
Use File | Import 
Once an image is within 
your stage, it will be 
selected
Right-click and send it to 
its own layer

For a Raster image, this 
creates a single layer that 
can be moved, colored, 
manipulated

Using the Property inspector to work with bitmaps
When you select a bitmap on the Stage, the Property inspector displays the bitmap's 
symbol name and its pixel dimensions and position on the Stage. 
To display the Property inspector:
1 Select an instance of a bitmap on the Stage.
2 Choose Window > Properties.
To assign a new name to a bitmap:
1 Select the bitmap in the Library panel.
2 In the Property inspector, enter a new name in the Name text box.
3 Click OK.
To replace an instance of a bitmap with an instance of another bitmap:
1 Select a bitmap instance on the Stage. 
2 Choose Window > Properties if the Property inspector is not visible.
3 In the Property inspector, click Swap. 
4 In the Swap Bitmap dialog box, select a bitmap to replace the one currently 
assigned to the instance.
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Importing Vector Images
Vector images can be imported with several 

options:
Pages = scenes

Each page of the vectored graphic becomes its 
own small movie

Pages = keyframes
Each page is assigned a different time period
Allows the image to be built up across time

Layers = Layers (safe) 
Layers = keyframes

Can manipulate each layer of an image across 
time

Layers flattened to make a raster image

The following vector/bitmap formats can be imported into Flash MX, regardless of whether QuickTime 4 is installed: 
File type Extension
Adobe Illustrator (version 8 or earlier .eps, .ai
AutoCAD DXF .dxf
Bitmap .bmp (Using QuickTime)
Enhanced Windows Metafile .emf
FreeHand .fh7, .fh7, .fh8, .fh8, .fh9, .fh9, .fh10
FutureSplash Player .spl
GIF and animated GIF .gif
JPEG .jpg
PICT .pct, .pic
PNG .png
Flash Player 6 .swf
Windows Metafile .wmf
The following vector or bitmap file formats can be imported into Flash MX only if QuickTime 4 or later is installed: 
File type Extension
MacPaint .pntg
Photoshop .psd
PICT .pct, .pic (As bitmap)
QuickTime Image .qtif
Silicon Graphics Image .sgi
TGA .tga
TIFF .tif
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Sample Vector Import

Import as Layers Import as keyframes

Notice the differences in the timeline.

For practice, import some of the images in the Flash MX/Samples/Images directory 
using the different options in the import tab.  
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Text
Text works similar to Adobe Photoshop
Inspector Panel contains initial settings; highlighted text can be 
modified after insertion

Font, family, size, color, fill, alignment, paragraph or letter spacing, 
orientation

The following special actions can be taken on text:
Break apart: sends each letter to its own layer

Text becomes individual text shapes
Link to a web page
Transform in any way possible

To create text, you place text blocks on the Stage using the Text tool. When creating 
static text, you can place text on a single line that expands as you type, or in a fixed-
width block (for horizontal text) or fixed-height block (for vertical text) that 
expands and wraps words automatically. When creating dynamic or input text, you 
can place text on a single line, or create a text block with a fixed width and height. 
A handle is displayed on a corner of text blocks to identify the text block type: 
•Static horizontal blocks that extend, round handle at upper right corner of text block.
•Static horizontal blocks with height, square handle at upper right corner of text block.
•Static vertical text with r-to-l orientation that extend, round handle at lower left corner of text block.
•Static vertical text with r-to-l orientation and fixed height, square handle at lower left corner of text 
block.
•Static vertical text with l-to-r orientation that extends, round handle at lower right corner of text 
block.
•Static vertical text with l-to-r orientation and fixed height, square handle at lower right corner of text 
block.
•Dynamic/input text blocks that extend, round handle at lower right corner of text block.
•Dynamic or input text with defined height and width, square handle at lower right corner of text 
block.
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Symbols
Reusable portions of a single Flash file

F11 – opens the symbol window
Flash stores action and motion as symbols, as 
well as shapes or elements of a flash movie.
Use File | Open as Library
Caveats:

Symbols are difficult to modify once added 
to the symbol library
Place on individual layers
Symbol characteristics are managed 
primarily through the inspector panel and 
transforms!
A crosshair in the middle of the stage denotes 
symbol editing mode

Each symbol has a unique Timeline and Stage, complete with layers. When you 
create a symbol you choose the symbol type, depending on how you want to use the 
symbol in the movie. 
•Use graphic symbols for static images and to create reusable pieces of animation 
that are tied to the Timeline of the main movie. Graphic symbols operate in sync 
with the movie's Timeline. Interactive controls and sounds won't work in a graphic 
symbol's animation sequence.
•Use button symbols to create interactive buttons in the movie that respond to 
mouse clicks, rollovers or other actions. You define the graphics associated with 
various button states, and then assign actions to a button instance. 
•Use movie clip symbols to create reusable pieces of animation. Movie clips have 
their own multiframe Timeline that plays independent of the main movie's 
Timeline—think of them as mini-movies inside a main movie that can contain 
interactive controls, sounds, and even other movie clip instances. You can also 
place movie clip instances inside the Timeline of a button symbol to create 
animated buttons. 
•Use font symbols to export a font and use it in other Flash movies. 
Note: To preview interactivity and animation in movie clip symbols in the Flash 
authoring environment, you must choose Control > Enable Live Preview.
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Layer Usage & Management
Eyeball – now you see it, now you 
don’t
Lock – can’t be changed
Color box – shows the outline of 
elements on that layer when layer is 
selected
You can create folders to manage 
like layers.
Every element – separate layer!
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Mask Layers
Used to hide portions of a 
Flash movie
Procedure for creating a mask:

Add new layer
create shape
right-click mask

To remove a mask layer, delete 
the mask

Note: mask layers are locked and 
invisible by default.  Unlock to 
change.

Before Mask

Create Shape Step

With Mask

To mask additional layers after creating a mask layer, do one of the following:
•Drag an existing layer directly below the mask layer.
•Create a new layer anywhere below the mask layer. 
•Choose Modify > Layer and select Masked in the Layer Properties dialog box.

To unlink layers from a mask layer:
1 Select the layer you want to unlink.
2 Do one of the following:
Drag the layer above the mask layer.
Choose Modify > Layer and select Normal.
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Importing Images
Flash MX supports all standard image types, excluding 
Adobe-only formats
EPS/PS are options for importing PDF layouts
Older versions of PSD are acceptable (pre-version 3.5)

Raster images must be modified to be used successfully.
Break Apart: The image is separated from its pixels and becomes 
a complete shape

Shaded (dimmed) to denote “broken apart” status
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Importing Raster Images
Raster images must be modified to be used successfully.

Break Apart: Modify | Break Apart
separated from its pixels to become a shape
Shaded (dimmed) to denote “broken apart” status

Convert to Vector: Modify | Trace Bitmap
Uses color, edge, and contour parameters to determine how to create a 
formula for preserving the image
Rough, but needed when individual parts of a raster image are needed in 
the animation

Note: Raster images can be used as fills.  Use the gradient fill tool (     ) to change a 
raster fill of a shape
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Animation Basics
The stage: where things happen
Actions: movement or changes occurring on the stage
Frames: the divisions of time within the animation
Keyframes: Frames where something action starts or ends
Guides: Helpers for development that are not published
Motion Layers: Guides for movement of objects that are not published
Timeline: a visual representation of the objects, actions, and events 

that occur within an animation
Controls: Think VCR!  Play, rewind, FF, pause

You create animation in a Macromedia Flash MX document by changing the 
contents of successive frames. You can make an object move across the Stage, 
increase or decrease its size, rotate, change color, fade in or out, or change shape. 
Changes can occur independently of, or in concert with, other changes. For 
example, you can make an object rotate and fade in as it moves across the Stage. 
There are two methods for creating an animation sequence in Flash: tweened 
animation, and frame-by-frame animation. In tweened animation, you create 
starting and ending frames and let Flash create the frames in between. Flash varies 
the object's size, rotation, color, or other attributes evenly between the starting and 
ending frames to create the appearance of movement. In frame-by-frame animation, 
you create the image in every frame. 
To simplify the process of creating tweened animation, you can distribute multiple 
objects to separate layers. You can use a mask layer to create a hole through which 
the contents of one or more underlying layers are visible. 
Note: You can also create animation programmatically using ActionScript to 
change the properties of an object, symbol, or instance. 
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Frames
Rules:

Display exactly the same content as the previous keyframe 
on the timeline
Add or delete frames to increase or decrease the amount of 
time the contents of a keyframe are displayed in a movie
Gray frames contain content; white frames do not.

Working with frames in the Timeline 
In the Timeline, you work with frames and keyframes, placing them in the order 
you want the objects in the frames to appear. You can change the length of a 
tweened animation by dragging a keyframe in the Timeline. 
You can perform the following modifications on frames or keyframes: 
• Insert, select, delete, and move frames or keyframes 
• Drag frames and keyframes to a new location on the same layer or on a different 
layer 
• Copy and paste frames and keyframes
• Convert keyframes to frames 
Drag an item from the Library panel onto the Stage to add the item to the current 
keyframe 
The Timeline provides a view of tweened frames in an animation. For information 
on editing tweened frames, see Creating Animation. 
Flash offers two different methods for selecting frames in the Timeline. In frame-
based selection (the default) you select individual frames in the Timeline. In span-
based selection, the entire frame sequence, from one keyframe to the next, is 
selected when you click any frame in the sequence.
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Keyframes
Rules:

A special type of frame used to cause a change in a movie.
It is a copy of the previous keyframe in a movie.
Controls appearance, position, all free transform elements
A used keyframe displays a black dot on the Timeline
An keyframe without content displays an empty dot on the timeline

To insert frames in the Timeline, do one of the following:
To insert a new frame, choose Insert > Frame. 
To create a new keyframe, choose Insert > Keyframe, or right-click (Windows) or 
Control-click (Macintosh) the frame where you want to place a keyframe, and 
choose Insert Keyframe from the context menu. 
To create a new blank keyframe, choose Insert > Blank Keyframe, or right-click 
(Windows) or Control-click (Macintosh) the frame where you want to place the 
keyframe, and choose Insert Blank Keyframe from the context menu.
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Frame/Keyframe Difficulties
Animation involves the manipulation of 12 or more frames of content 

per second.  Every frame is an element that may require individual 
attention.

Fine mouse control is needed.
Ensure that a frame is selected before performing a frame action.
Always check the timeline.  Are you in the right frame?
Dragging across multiple frames for selection is desired, but it takes 

practice.
Keyframes creation order: object/layer, beginning, insert, action

To delete or modify a frame or keyframe, do one of the following:
To delete a frame, keyframe, or frame sequence, select the frame, keyframe, or 
sequence and choose Insert > Remove Frame, or right-click (Windows) or Control-
click (Macintosh) the frame, keyframe, or sequence and choose Remove Frame 
from the context menu. Surrounding frames remain unchanged.
•To move a keyframe or frame sequence and its contents, drag the keyframe or sequence to the 
desired location. 
•To extend the duration of a keyframe, Alt-drag (Windows) or Option-drag (Macintosh) the 
keyframe to the final frame of the new sequence duration.
•To copy a keyframe or frame sequence by dragging, Alt-click (Windows) or Option-click 
(Macintosh) and drag the keyframe to the new location.
•To copy and paste a frame or frame sequence, select the frame or sequence and choose Edit > Copy 
Frames. Select a frame or sequence that you want to replace, and choose Edit > Paste Frames.
•To convert a keyframe to a frame, select the keyframe and choose Insert > Clear Keyframe, or right-
click (Windows) or Control-click (Macintosh) the keyframe and choose Clear Keyframe from the 
context menu. The cleared keyframe and all frames up to the subsequent keyframe are replaced with 
the contents of the frame preceding the cleared keyframe.
•To change the length of a tweened sequence, drag the beginning or ending keyframe left or right. To 
change the length of a frame-by-frame sequence, see Creating frame-by-frame animations.
•To add an item from the library to the current keyframe, drag the item from the Library panel onto 
the Stage.
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Insert Keyframes Exercise
The Jumping Ball

Using keyframes, make the 
ball jump across the screen 

every 5 frames.

Your animation should 
contain 3 keyframes, 1 layer, 

and 1 object.



39

Technology Training
January-February 2003

Tweening

Automating the creation of frames to simulate an action or actions.  
Main reason for computer-based animation.

Flash can tween position, size, rotation, and skew of instances, groups, and type. 
Additionally, Flash can tween the color of instances and type, creating gradual color 
shifts or making an instance fade in or out. To tween the color of groups or type, 
you must make them into symbols. To animate individual characters in a block of 
text separately, you place each character in a separate text block.
If you apply a motion tween and then change the number of frames between the two 
keyframes, or move the group or symbol in either keyframe, Flash automatically 
tweens the frames again. 
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Motion Tweens
An animation sequence that moves or changes an object.  

To create a motion tween:
Specify two keyframes that each display an object in a different location, rotation, 
size, or color

Select the starting keyframe
Shift-Left Mouse Click on the ending keyframe
Right Click (or Insert | Motion Tween) and select Create Motion Tween
Test your tween by moving the timeline slider between the two points

To remove a motion tween:
Right click on a frame within the tween
Select Remove Tween

Click on a tween line (line w/arrow) to see options for the tween in the Inspector 
Panel

To create a motion tween using the Create Motion Tween command:
1 Select an empty keyframe and draw an object on Stage, or drag an instance of symbol from Library 

panel. In order to create a tween, you must have only one item on the layer.
2 Choose Insert > Create Motion Tween. If you drew an object in step 1, Flash automatically 

converts the object to a symbol and assigns it the name tween1.
3 Click inside the frame where you want the animation to end, and choose Insert > Frame. 
4 Move the object, instance, or type block on the Stage to the desired position. Adjust size of element 

to tween its scale. Adjust rotation if you want to tween rotation. Deselect the object when you 
have completed adjustments.  A keyframe is automatically added to the end of the frame range.  

5 Drag the arrow next to the Easing value or enter a value to adjust the rate of change between 
tweened frames:  Negative numbers begin the motion tween slowly and accelerate the tween 
toward the end of the animation.  Positive numbers begin the motion tween rapidly and 
decelerate the tween toward the end of the animation
By default, rate of change between tweened frames is constant. 

6 To rotate the selected item while tweening, choose an option from the Rotate menu: 
Choose Auto to rotate the object once in the direction requiring the least motion. 
Choose Clockwise (CW) or Counterclockwise (CCW) to rotate the object as indicated, and then 
enter a number to specify the number of rotations.

7 For a motion path, select Orient to Path to orient baseline of tweened element to motion path. 
8 Select Synchronize to ensure that the instance loops properly in the main movie. 
9 If you're using a motion path, select Snap to attach the tweened element to the motion path by its 

registration point.



41

Technology Training
January-February 2003

Insert Motion Tween Exercise
The Sliding Ball

Using keyframes, make the 
ball slide across the screen 

every 5 frames.

Your animation should 
contain 3 keyframes, 2 

motion tweens, 1 layer, and 1 
object.
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Motion Layers
A special layer that controls the direction of an object’s motion.

Important: Complements, does not override, the motion defined by
motion tween.

How to create a motion layer:
Select a layer in the layers window that contains the motion tween you wish to 
modify.
Right-click and select Add Motion Guide
Click on paint brush or pencil tool
Draw the path you wish the object to follow
Once finished, click on the timeline (or off of the stage somewhere)
Test the guide

To link layers to a motion guide layer, do one of the following:
• Drag an existing layer below the motion guide layer. The layer is indented under 

the motion guide layer. All objects on this layer automatically snap to the 
motion path.

• Create a new layer under the motion guide layer. Objects you tween on this 
layer are automatically tweened along the motion path.

• Select a layer below a motion guide layer. Choose Modify > Layer and select 
Guided in the Layer Properties dialog box.

To unlink layers from a motion guide layer:
1. Select the layer you want to unlink.
2. Do one of the following:

1. Drag the layer above the motion guide layer.
2. Choose Modify > Layer and select Normal as the layer type in the Layer 

Properties dialog box.
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Motion Guide Exercise
The Sliding Ball

Using keyframes, make the ball 
wiggle across the screen every 5 

frames.

Your animation should contain 3 
keyframes, 2 motion tweens, 1 
normal layer, 1 motion guide 

layer and 1 object.
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Other Motion Tween Options
Rotation

Use the Inspector Panel for a tween for rotation options

Scale
Color

Restricted to symbol instances
Convert other objects to symbols before attempting color-based 
motion tweens

To tween the color of groups or type, you must make them into symbols.

To animate individual characters in a block of text separately, you place each 
character in a separate text block.
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Shape Tweens
An animation sequence that reformats/transfigures an object.

Can be VERY machine intensive if working with converted raster images. 
Best bet: convert vector shapes to vector shapes.

To create a shape tween:
Specify a single keyframe that contains the starting shape
Create a keyframe at the end of the sequence and draw your destination shape
Select the starting keyframe and choose Shape for the Tween type on the Inspector Panel
Modify the options on the Inspector panel as you see fit
Test your tween by moving the timeline slider between the two points
Add Shape Hints (Modify | Shape | Add Shape Hint) to guide the transformation, if needed.

To remove a shape tween:
Right click on a frame within the tween and Select Remove Tween

Click on a tween line (line w/arrow) to see options for the tween in the Inspector Panel

Blending options are available for shape tweens: 
• Distributive creates an animation in which the intermediate shapes are 
smoother and more irregular.
• Angular creates an animation that preserves apparent corners and straight 
lines in the intermediate shapes. 

Note: Angular is appropriate only for blending shapes with sharp corners and 
straight lines. If the shapes you choose do not have corners, Flash reverts to 
distributive shape tweening.
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Scenes & Clips
A scene is a segment of a movie that has its own timeline and stage.  

It eases development of long animations by breaking the 
animation into more manageable pieces.

A movie clip is a reusable animation that acts like a mini-movie in a 
document.  A movie clip has its own timeline.

Both of these elements are critical to advanced Flash animation.
See the resources on the last slide for more information.
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Creating a Button
Buttons are a type of symbol with a pre-

defined timeline and keyframe set.
Create an object that looks like your 
desired button – INCLUDE TEXT
Select the object
Right-click and select Convert to 
Symbol 
Give the new button a name
Select “Button” as the behavior type
Click OK
Press F11 to view your symbol in the 
library

This is the ONE “must-have” 
within Flash MX!
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Editing a Button
Once your button exists in the Library, double-click to edit it in 
Symbol Editing Mode.
Make a change to each of the keyframes contained in the button 
element:

Up – how it will look on a web page before any action is taken
Over – the mouse enters the edges of the button
Down – the mouse is clicked on the button
Hit – normally not displayed, but acts like a light switch (on until turned off)

Remember, to edit any object, you must select it first, either with the black or white 
arrow tool.  Also, the paint bucket and ink well tools can be used to modify fills 
or lines, respectively.
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Adding Sounds to Buttons
Verify that the sound is short and non-intrusive.

Supported types: WAV, AIFF, MP3
Will significantly increase the file size of your animation

Choose File | Import to Library
Choose the file and click Open
In your movie, select the button which you want attached to the 
sound.
In Symbol Editing Mode, add a new layer for the sound.
Create a keyframe for the state that will use the sound
Select the sound in the Library
Drag the sound to the stage
Test the sound

You can associate sounds with the different states of a button symbol. The sounds 
are stored with the symbol and work for all instances of the symbol. 

To add sound to a button:
1. Select the button in the Library panel.
2. Choose Edit from the options menu in the upper right corner.
3. In the button's Timeline, add a layer for sound. 
4. In the sound layer, create a regular or blank keyframe to correspond to the 

button state to which you want to add a sound. For example, to add a sound that 
plays when the button is clicked, create a keyframe in the Down frame. 

5. Click the keyframe you have just created.
6. In the Property inspector, choose a sound file using Sound pop-up menu.
7. Choose Event from the Synchronization pop-up menu.
8. To associate a different sound with each of the button's keyframes, create a 

blank keyframe and add another sound file for each keyframe. 



50

Technology Training
January-February 2003

Linking a Button
Select the button on the 
stage
Click on the Actions 
Panel
In the Actions Panel

Actions | BrowserNetwork
Double click on getURL

Enter Address in URL
Select separate window, if desired

Close the Action Panel and test your button

Links from buttons are sometimes necessary, but not a good idea. It is easier to 
maintain and update links by using HTML and Dreamweaver than Flash MX.  Only 
embed a URL in a button when the destination is ALWAYS static or the link is 
external to your site and will NEVER be moved.
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Using Pre-Built Actions
Pre-made components

Buttons
Quiz Templates
Sounds

Photo Templates
Presentations
Ads

Thousands of components available at 
http://www.macromedia.com/desdev/mx/flash/
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Publishing
Always check publishing 
settings before exporting 
JPEG quality settings have a 
huge affect on file size

Choose File | Publish Preview 
to view your finished movie.
Once satisfied, choose File | 
Publish to create the final 
SWF.

Default save extension: FLA


